Teleform Connector for ImageQuest

TeleformConnector for ImageQuest 

The TeleformConnector integrates with Teleform and enables Teleform batches to be committed to IQ. The TeleformConnector must be installed and configured on each machine that will handle or perform Teleform batch commits.

TeleformConnector Requirements

  • ImageQuest server
  • Teleform client install with Basic Script enabled (Utilities -> Configuration -> Configuration Options tab, select Enable BasicScript Editor from the Options list, check Enable and click OK)
  • NET 4.0 Client Profile

Install and configuration

  1. Run the TeleFormConnector.msi on the machine(s) that will handle or perform Teleform batch commits.  It will install to the following location C:\Program Files (x86)\Informa Software\ImageQuest.
  2. Modify the Informa.ImageQuest.TeleFormConnectAgent.dll.config to reflect the proper values for IQWebServices (the IQ servername) and DefaultCabinet (IQ database name)
  3. Copy the contents of the SystemScript.vbs (right-click, Edit or Open with Notepad) into the TeleForm System Script ‘Edit Script’  window (TeleForm Designer -> Utilities -> Export/System Scripts -> BasicScript) and then select File -> Compile and then File -> Save.  Note:if the form has existing System Script, you will need to add the correct IQ SystemScript to the correct entry points.
  4. Create a new TeleForm Export Script (TeleForm Designer -> Utilities -> Export/System Scripts -> BasicScript).  Select File -> New -> Export Script and copy the contents of the ExportScript.vbs (right-click, Edit or Open with Notepad) into the script window and then select File -> Compile and then File -> Save.  Save the new script as “ImageQuest”.
  5. On each form in TeleForm Designer, add a virtual field called DocumentType and use the IQ Document Type (created in IQ Administrator) name for the default value in the Output tab.
  6. On each form in TeleForm Designer, add an IQExportConfig virtual field.  Note: this is NOT required for single cabinet installations.  See ADDITIONAL NOTES for configuring TeleformConnector in a multi-cabinet environment.
  7. Create a new ImageQuest export (Teleform Designer -> Form menu -> Auto Export) for each TeleForm template. Select ImageQuest from the Format list (located in the Main tab of the Auto Export Setup dialog box).  Save the export to C:\Program Files (x86)\Cardiff\Teleform\exp and give the file a unique, meaningful name (ex: the Teleform form name).
  8. Map the fields in the export for fields (attributes) the user will use for search in IQ. Search fields must also be attributes in IQ and assigned to the IQ Document Type (configured in IQ Administrator). In addition, the following fields MUST be mapped in the Auto Export: DocumentType, SuspenseFile and IQExportConfig (if virtual field IQExportConfig is being used). Note: DocumentType, SuspenseFile and IQExportConfig do not need to exist as attributes in IQ.
  9. Enable and save the export and then Save the form template.
  10. Close down all TF applications, so the new scripts are accessible when you load the TF apps again.
  11. Copy the tfreader.exe.config and tfverify.exe.config files to C:\Program Files (x86)\Cardiff\TeleForm on the machine(s) that will be performing commits from TeleForm
  12. For the Job Config, uncheck “Skip previously exported forms when re-committing”. See example below. If you skip previously exported forms, the batch will say it exported successfully, but nothing gets exported to ImageQuest and the batch will be “lost”.

1

FYI – When an error does occur and the batch is recommitted, the following dialog box will appear.  The user must click NO in order for the batch to succeed. If the user presses YES, the batch will appear to commit, but noting will export to IQ.

2

ADDITIONAL NOTES:

  • The TeleformConnector does NOT support Non-batch processing
  • The TeleformConnector scripts are NOT supported with VBA (Visual Basic for Applications).
  • If IQocr is installed and licensed, you can enable full text Ocr for images exported from Teleform by adding a virtual field on the form called NeedsOCR with a default value of 1.  NeedsOCR will also need to be mapped in the Auto Export.
  • The TeleformConnector supports multi-cabinet environments, but it requires the creation and configuration of an ExportConfig.xml file (within the TeleformConnector directory).  An IQExportConfig virtual field MUST be added to each form and the default value must reference either the DefaultCabinet (Informa.ImageQuest.TeleFormConnectAgent.dll.config) or the name of the ExportConfig Name value from the ExportConfig.xml to ensure the forms export to the correct cabinet.  The following is an ExportConfig that includes keys for custom filters:

<ConfigSettings>

                <ExportConfig Name=”VOA”>

                                <Cabinet>ImageQuest</Cabinet>

                                <FormFilter FileName=”Custom.TFFilter.dll” ClassName=”Custom.TFFilter.Filter /”>

                </ExportConfig>

</ConfigSettings>